iDRAC – Remote keyboard not working

There was an issue whilst trying to install a new VMware ESXi host on a DELL PowerEdge R630 remotely (from iDRAC): The remote keyboard was not working from iDrac after booting into the ESXi installation but it did work correctly in the BIOS.
Basically the installation was waiting for somebody to press Enter to continue which didn’t work.

esxi-installation-enter-continue

A few steps were tried to resolve the issue but in this specific case the problem was finally solved once USB 3.0 was disabled from the Bios! Specifically to this server’s bios version it’s in System Bios > Integrated devices > USB 3.0 Settings > Disabled.

poweredger630-bios-disable-usb-3-0

The other options that were tried with no luck were:

  • Upgraded all devices’ firmware to the latest versions.
  • Get in the BIOS>integrated device, disable the Memory Mapped I/O above 4GB option [This was suggested by DELL Support].
  • Checked iDRAC’s session options to Pass all keystrokes to server.
    • idrac-session-options-pass-all-keystrokes-to-server
  • Changed from Java to HTML5 in the iDRAC console settings.

Leave a Reply

Your email address will not be published. Required fields are marked *